Custom verifier of Twitter using Auth0 is not getting recognized

The default verifier is being called for twitter mode of login instead of the custom verifier which is live. Our w3Auth version is 3.2

twitter: { verifier: "prod-auth0-test-twitter-verifier", typeOfLogin: "twitter", clientId: "auth0-client-id" }

Can you please help us in integrating twitter

@devtools Thanks for your recent post.

Your request has been forwarded to our team and we will get back to you with further updates once more information becomes available.

Hi, please follow our guide on how to integrate custom auth at

@tai.nguyen Thanks for the respone! We have already tried this out and this other link: Federated / Identity Providers | Documentation | Web3Auth

The Web3Auth throws client not found error (the Auth0 client using is valid). The code snippet is there in the opening discussion, let me know if there is something I have missed.

can you use jwt instead of jwt and see if it works?
"jwt": { ... "typeOfLogin": "jwt" ..}

Insted of "twitter " I have used as you suggested with

jwt: {
        name: "Pay3 Passwordless",
        verifier: "prod-auth0-twitter-verifier",
        // verifierSubIdentifier,
        typeOfLogin: "jwt", // Pass the type of login provider. For Auth0, it's jwt and not Auth0.
        clientId: "auth0-clienti-id", 

I tried using this above snippet but it uses the torus’s default verifier

@tai.nguyen @vjgee Can you please help in this, we are stuck in this since a long time

1 Like

Hey @devtools

Please try the code that has jwtParameters in it when using CustomAuth in Modal.

            twitter: {
                verifier: "web3auth-auth0-demo",
                typeOfLogin: "jwt",
                clientId: "294QRkchfq2YaXUbPri7D6PH7xzHgQMT", // auth0 client ID
                jwtParameters: {
                  domain: "", // Auth0 domain
                  verifierIdField: "sub",

Thanks a lot for the help, it worked!