Portuguese translation is not available for Openlogin


Some time ago I helped create the Portuguese translation for Web3Auth-locale and Openlogin-locale strings. The key is “portuguese” for both.

However, I’ve noticed that while Web3Auth locale is working quite well, for the Openlogin flow the Portuguese locale is not working. Is there something else we need to update for it to be recognized?

Thanks a lot!

Hello @furtado,

Have you included whitelabeling when initializing OpenLogin? If not, it’s recommended that you do so. You can follow the instructions provided at Openlogin Adapter for Social Logins | Documentation to do this.

1 Like

Hi there! Thanks for the reply. Yes, I have indeed included the whitelabel option when initializing. Even with it, the translation is not working. :frowning:

Hey @furtado

I have informed the relevant team and will update you on any developments regarding the issue.

Thank you.

1 Like

I also have same issue. Is there anything we should do to make it work? Cheers

1 Like

Hey @furtado and @rodrigo,

Thank you for your patience. We would like to inform you that a new version will be released soon, which will include the support you have been waiting for. You can expect it to be available by the end of the day (EOD).

Thank you for your understanding and support.

Thanks a lot, @shazadshiraz97! Really appreciate it. It would also be great to offer some whitelabelling capability in the openlogin flow. Perhaps it will already come together with the fix. :slight_smile:

Hey @furtado @rodrigo

v6 is now released. You can now try the pt translation on Modal and User Flow Screens.

import { Web3Auth } from "@web3auth/modal";
import { CHAIN_NAMESPACES } from "@web3auth/base";
import OpenloginAdapter from "@web3auth/openlogin-adapter";

const web3auth = new Web3Auth({
  // type uiConfig
  uiConfig: {
    defaultLanguage: "pt", // en, de, ja, ko, zh, es, fr, pt, nl
  chainConfig: { chainNamespace: CHAIN_NAMESPACES.EIP155 },
  web3AuthNetwork: "cyan",

const openloginAdapter = new OpenloginAdapter({
  adapterSettings: {
    whiteLabel: {
      defaultLanguage: "pt", // en, de, ja, ko, zh, es, fr, pt, nl

await web3auth.initModal();

await web3auth.connect();

Hi @shahbaz,

I’m encountering an issue while setting the language to “pt” and using the passwordless e-mail authentication (providing a login_hint). If I set language to “pt” on this endpoint https://admin.openlogin.com/api/v2/auth/passwordless/start I get the following error:

“statusCode”: 400,
“error”: “Bad Request”,
“message”: “Validation failed”,
“validation”: {
“body”: {
“source”: “body”,
“keys”: [
“message”: “"whitelabel.language" must be one of [en, de, ja, ko, zh, es]”

Making exactly the same request while setting the language to “en” works as expected.

“success”: true,
“message”: “Initiated successfully”,
“data”: {
“trackingId”: "SOME TRACKING ID,
“verificationCode”: “SOME CODE”

I appreciate guidance/help; I can provide additional information if necessary :slight_smile:

Hi @shahbaz,

Just a quick follow-up on the issue I reported three days ago. I’m still unable to set the language to “pt” for passwordless email authentication. I’d appreciate any update or additional guidance.

Here is the error the user sees:


Hey @pedro

I have reported this to the product team. They are looking into this. I will keep you posted on the update here. Apart from email passwordless, the openlogin screens should be available in Portuguese.

1 Like

Hi @shahbaz ,

Just getting in touch to check whether the product team has had the opportunity to take a look at this issue.


Hi @pedro,

I apologize for the delay. There is a new PR out for merging(expect it out by this week), but it required more time than initially anticipated due to additional work that was necessary.

Hello @pedro and team

I am thrilled to announce that Email passwordless flows now support Portuguese translations, as well as all other supported languages.

Please confirm on your end.

1 Like

Thanks a lot, @shahbaz . Super happy to hear this, we will soon have it live on our product. :partying_face:

1 Like

Looking forward to seeing your product going live with web3auth, that too in Portuguese.

Do share the links once it goes live.

Hi @shahbaz ,
It’s live (with the web3auth integration in portuguese!) here: https://picnicinvestimentos.com/
Thanks a lot for what you guys have been building.

1 Like

Hey @pedro

Thanks for sharing! Just signup. The flow looks great!

Hey @shahbaz , great that you like it. We’re working hard on getting it as simple as it gets.

However, we would love to receive some help for an issue that is affecting around 40% of all users from Brazil. We’re struggling to receive assistance for it, so I’m desperately calling for help in this unrelated topic here.

It would be great if we could count with your help on this as well.

The issue is described in the following topic: "unable to detect login share" error on Plug n Play - #5 by pedro


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.