Unable to authenticate user, `idToken` is an empty string

Pretty much out of the blue, one of our apps are unable to authenticate the user properly.

Recently the idToken is coming up as an empty string from the result of web3auth.getUserInfo() or web3auth.authenticateUser().

We need the idToken to authenticate the user of course — as exemplified in the docs.

I can’t find any topics or information about why the idToken can be empty.

Any insight into this would be really appreciated.

Thank you!

1 Like

Same issue here, any idea?

Hey @wahid and @mehdi

To provide better assistance, kindly share your initialization and login code snippet. Also, which version of @web3auth/modal are you using?

Thanks for taking back at it.
Actually this is solved by going to Testnet from Cyan.

However, this is the packages version we are using:

"@web3auth/base": "^4.0.0-alpha.0",
"@web3auth/core": "^4.0.0-alpha.0",
"@web3auth/openlogin-adapter": "^4.0.0-alpha.0",
"@web3auth/web3auth": "^2.1.3",

Please upgrade to the latest version 5.x
The problem should be solved then.
Testnet should not be used in production

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.