Wallet connect on metamask cannot connect if user are on the same chain as setup

For example:

  • In the code we setup the chain as polygon mumbai
  • User try to login through walletconnect with metamask, if they are on sepolia it will throw an error
  • If they setup to polygon mumbai then they can login

@richard.lee1 Thanks for reaching out.

Your issue has been forwarded to our team and we will get back with further updates once more information becomes available.

Are you using the latest version of WalletConnect V2? Are you adding the chainId as hexadecimal or decimal format inside the getWalletConnectV2Settings ? I’ll link the example here for your reference.

Thank you for your quick response. we already doing this
chains[0].id is the only chain we supported.


I’ve reported the issue to our Dev team and will keep you updated on the progress for a fix.

Hi @vjgee, do you have any updates on the issue?. We have updated it to v7 but the error still exist.

I’ve already flagged this to our team and waiting for a response from them.

1 Like

There’s an issue with walletconnect where only mainnet chains can be configured in the array that we send while setting up walletconnectV2Adapter

1 Like

Thanks @maharshi for your response. I’ve also tried to set chain id to mainnet (1) but encounter the same error.