Web3auth no-modal Social auths are not working

I was successfully able to write code that allows authentication with social auths (includes google, twitter and discord) and with external wallets (includes metamask, coinbase and walletconnect).

The implementation was working very well.

But in past 1-2 days the implementation with social auths has stopped working. I did not change anything in the code.
I have tried clearing cache which did not work. I tried with different browsers as well. But still the same issue.

I have attached the image which includes the errors that come up when trying to authenticate. If any more details are required than let me know.

Let me know what could the potential solution for the problem.

Thank you.


Your request has been forwarded to our team and we will get back to you with further updates once more information becomes available.
Is it possible to share a working url of your application?

Hello @vinayak ,
Thanks for responding and forwarding our request to your team.

Currently the application is not deployed yet. We are doing local testing. This behaviour was observed then. If you require the test link to debug the issue let us know we will provide the same.

Let us know what could be the reason that it suddenly started to fail.

Hello @vinayak ,

Could you please provide an update on our query as it is an important task and requires immediate attention. Please let us know what could be the fix for it.

Thank you

Sure . Am following up on this.
@shubbham.jain - Can you please attach the chain config and the other parameters being passed to the Web3AuthNoModal constructor? This would help in debugging faster.

Thank you @vinayak for the immediate response, really appreciate it. Keep me posted if anything comes up.

Hey @shubbham.jain

As I see the polygon request failing is the reason why web3auth is not being connected. Did you pass an rpcTarget for the URL which is showing 401 in your console? If yes please check your alchemy dashboard. Feel free to use another rpc provider, like infura or quicknode in case it doesn’t work out.