Whitelisted domain, but error in app says it cannot validate redirect

Hi there, I am having an issue whitelisting the domain for my site. I can confirm that it is whitelisted in the web3auth dashboard and that the url matches the domain I am using. From everything I can see the setup seems correct.

Here is my setup in web3auth dashboard:

This is the error in the console when using web3auth login from my site:

Error: could not validate redirect, please whitelist your domain: https://songstache.xyz for provided clientId vkqDxwao7kJf5eVfMQY1j1cOpdjsTRHn4e2LsSUb9Q6FOstcGgGLjGgbgTwJ7_CERNZ8ta0c4u05_HB6tQ at https://dashboard.web3auth.io

I have verified the Client Id in my code matches the above Client ID from the logs. I have a prototype deployed at https://songstache.xyz/alpha/explore to show the current issue.

Is anyone able to help clear this up?

Originally posted by: kgilliam125

Check the discussion at: https://github.com/orgs/Web3Auth/discussions/539

Hey, you are passing incorrect clientId, your correct client_id is : BK6N-vkqDxwao7kJf5eVfMQY1j1cOpdjsTRHn4e2LsSUb9Q6FOstcGgGLjGgbgTwJ7_CERNZ8ta0c4u05_HB6tQ

Note you are missing initial BK6N- prefix

Originally posted by: himanshuchawla009

@himanshuchawla009 Can you please check?

Originally posted by: girishvi

i! HI have this page deployed but when I want to sign in don't have permissions


I have my website in whitelist and it doesn't work either


Originally posted by: salviega

Hello, When is possible to fix this issue?

Originally posted by: AkioAlex0817

seems this has been days without a fix. luckily it's only happening on our testnet. if it was production, our service would be down for 4 days. what is the SLA at web3auth?

Originally posted by: billtlee
1 Like

Hi, I'm using subdomains and getting the same error in testing.
This all worked earlier today, but suddenly subdomains stopped working with your infrastructure this afternoon.
I can successfully login to an app with localhost but app.localhost no longer works.

Did you guys change how you validate domains today? Can we get this fixed asap if it's broken?
Doing a login with http://app.localhost:3000 that's giving me
Error: could not validate redirect, please whitelist your domain: http://app.localhost:3000/ for provided clientId BFHgaoa-H_IEFjVx8w63gy5OEfGUCTTxoPkor9RmUbTscH_GTl0ui4MDlXJU1aIFRLmtHmvb2ckpzt1g0CU3tUw at https://dashboard.web3auth.io/
This app was working previously, but just stopped. Any ideas?

Originally posted by: amberfi

Hi! I'm also using subdomains and get this kind of error. Can it be fixed somehow? Looks like it's on your end - the issue when using subdomain.

My subdomain is whitelisted and the clientID is also correct.

loglevelSentry.esm.js:72 Error: could not validate redirect, please whitelist your domain: https://app.bank11.io for provided clientId BI06CntgSiQ47egM5qMqkOOCzC5xN5ZeaRrHXGpb8PhJdTN1gwqX0r9okLKPcMKx5pXeJK-xl0WAb5pHpmlK4gY at https://dashboard.web3auth.io

Originally posted by: dimitrymd

We are also having the same error

Originally posted by: billtlee

Any updates on this? Same issue on our end.


In our case the issue was with the adapter settings.

OpenloginAdapter has a adapterSettings with network option. The network has to be in line with configuration at https://dashboard.web3auth.io.

We just had to set it to testnet so the openlogin callls whitelist url with correct param: